Buy the print and get FREE access to our online edition!

Tech Forum

January 2017

Uno-Known Device

I’ve used the Arduino IDE with a genuine Arduino Uno board for experiments for a few months without trouble. Recently, I wanted to permanently put an Uno in a desktop project, so I purchased some budget Arduino Uno compatible boards. The budget boards seem fine, but the Arduino IDE doesn’t recognize any of them. When connected, the boards show up as an “Unknown Device.” I am using Windows 7 32-bit. Does anyone have any pointers on how to make this board work?

Michael Allison
Camden, NJ


This is a MINOR manufacturing defect, easily repaired! Turn the unit over, so the USB connector is on the bottom, and facing left. That "large" IC on the left is the USB controller. Solder pins 25 and 26 together, and your problem will be solved. One of those pins is ground. The other is a "test" pin that is SUPPOSED TO BE grounded, but isn't. Once grounded, the chip works correctly. I did this with a board I bought from MPJA, and it solved my problem instantly.

William Barnett
West Haven, CT

Some of the cheaper Uno and Nano board spinoffs (among other off shore versions) use the CH340G series USB serial interface chip rather than the FTDI USB chip. All that is necessary is to download the CH341 driver and install it in your Windows/Mac system. You can get the driver from or Google search “”. Just make sure your comm port settings in the software match the USB driver in Windows. You can leave both drivers in Windows without uninstalling the other.

Rick Choy
Winchester, VA

On the bottom of the Nano board, are a few chips. One of them is much larger than the rest. That is the USB chip. You need to create a solder bridge between pins 25 and 26. One of those pins is GROUND and the other is a manufacturer’s TEST input... which they left floating. It needs to be grounded. Once you solder those pins together, your Nano will work. I’ve done this fix twice, now, and it solved my issues 100%.

William Barnett
West Haven, CT